Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 22, 2025 - 23:00 CEST
Scheduled
Crédit Mutuel has informed us that they will be performing a maintenance on October 22nd from 11PM to 2AM (UTC +2). Users may not be able to synchronize their accounts during this time.
Posted Oct 21, 2025 - 17:11 CEST
This scheduled maintenance affected: Transaction Data - Connectors (Credit Mutuel).