Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 19, 2025 - 10:00 CEST
Scheduled
BforBank has informed us that they will be performing a maintenance on May 19th from 10am to 11am. Users will not be able to synchronize their accounts during this time.
Posted May 19, 2025 - 09:03 CEST
This scheduled maintenance affected: Transaction Data - Connectors (BforBank).