Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 28, 2025 - 01:00 CEST
Scheduled
Société Générale has informed us that they will be performing a maintenance on September 28th from 1AM to 2:45AM (UTC +2). Users will not be able to synchronize their accounts during this time.
Posted Sep 25, 2025 - 12:15 CEST
This scheduled maintenance affected: Transaction Data - Connectors (Société Générale).