Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 28, 2026 - 07:00 CEST
Scheduled
BforBank has informed us that they will be performing a maintenance on April 28th from 07:00 to 14:00 (CET). Users will not be able to synchronize their accounts during this time.
Posted Apr 21, 2026 - 16:16 CEST
This scheduled maintenance affected: Transaction Data - Connectors (BforBank).